in Search
Latest post 08-02-2011 1:20 PM by stefan. 1 replies.
Page 1 of 1 (2 items)
Sort Posts: Previous Next
  • 08-02-2011 8:42 AM

    • nv
    • Not Ranked
    • Joined on 07-14-2010
    • Posts 4
    • Bronze Member

    No power from my Beolab 7 speaker to my TV

    After searching the forum I could not find an answer to what seems like a small and simple problem, so here it is:

    I changed my Beolab 7-1 for a 7-4 (because in surround setup I think it sound much better). Upon installing I noticed the power out socket on the back of my new 7-4 was covered with some sort of plug. I took that out and plugged the power cord (the short one, to loop from speaker to TV) of the TV (Beovision 7) in. Unfortunately nothing happened. The TV doesn't seem to have power.

    I searched for a switch to turn the power out on but couldn't find anything.

    Does anyone know how I can fix this?

  • 08-02-2011 1:20 PM In reply to

    • stefan
    • Top 50 Contributor
      Male
    • Joined on 04-16-2007
    • 200 miles from Struer
    • Posts 1,733
    • Founder

    Re: No power from my Beolab 7 speaker to my TV

    I don`t know where yoa are located, but as far as I know it is not allowed in Europe (anymore) to loop through mains. That`s why there is a cover on the plug. You have to connect BV and BL separately to the mains.

    Stefan

Page 1 of 1 (2 items)
Need a cable? Just ask Steve at Sounds Heavenly Need a cable? Just ask Steve at Sounds Heavenly Need a cable? Just ask Steve at Sounds Heavenly
Beoworld Security Certificate

SSL