Search

Page 1 of 1 (5 items)
  • Beomaster 2000 1974 - 1978 help

    Hi Everyone, I have just brought a beomaster 2000 amp and it has a horrible humming noise that comes out of the speakers. The hum is only there when a input - tape,phono or radio is selected at low volume you cant really here the noise but when you turn the volume up the hum gets worse. I have tried a few different sets of speakers and its exactly the
    Posted to Vintage Products (Forum) by lewist on 03-01-2012
  • Re: Beocenter 2600

    Hi Martin, Thank you for your reply once again if the problem gets worse I will take it back to the repair shop and point those points out although I do think its the potentiometer. All I think the man has done is clean all the controls. But its not doing to badly considering its age. Thank you for all your kind help. Lewis
    Posted to Vintage Products (Forum) by lewist on 08-11-2011
  • Re: Beocenter 2600

    The Speakers seem fine its deffinatly the right channel on the beomaster that is having the problems.
    Posted to Vintage Products (Forum) by lewist on 08-11-2011
  • Re: Beocenter 2600

    Hi Martin, Thank you for your reply i have just tried what you said and the problem is still their so I think the problem must be with the Beocenter itself
    Posted to Vintage Products (Forum) by lewist on 08-11-2011
  • Beocenter 2600

    Hi Everyone, I am new to Beoworld, I have a Beocenter 2600 its a lovely unit it has 2 Beovox s35 speakers it has been working fine since I brought in last year second hand but all of a sudden it has started to play up the problem is with the Volume the trouble only seems to occur on Right Channel. The balance is level between the 2 channels but I find
    Posted to Vintage Products (Forum) by lewist on 08-11-2011
Page 1 of 1 (5 items)
Need a cable? Just ask Steve at Sounds Heavenly Need a cable? Just ask Steve at Sounds Heavenly Need a cable? Just ask Steve at Sounds Heavenly
Beoworld Security Certificate

SSL