in Search

Browse Forum Posts by Tags

Showing related tags and posts for the Products Related Forums group. See all tags in the site
All Tags » Restoring (RSS)
  • Re: Beomaster 5500 problem....

    Martin, Eugene, Peter, thanks very much for your replies and suggestions. Having checked the back again it was indeed the main left speaker (lower socket), and there was some resistance when plugging in, the speaker was silent on all sources including radio and I checked the balance which was fine with...
    Posted to Vintage Products (Forum) by roccodog on 04-29-2011
  • Beomaster 5500 problem....

    Hello all, this is my first posting as I have just put together a beosystem 5500 with four beovox s45 speakers and I am in love! The system looks and sounds like it was made yesterday and the MCP is quite a conversation piece. I do have one small problem though - the left hand socket for the secondary...
    Posted to Vintage Products (Forum) by roccodog on 04-29-2011
  • Beovox s45-2 restoration( With bonus "Paen" to Beogram 4002)

    I'm in need of some advice on restoring a pair of Beovox s45-2's, but before I ask my questions, I'd like to say how much I've enjoyed reading through this site and following the conversations of people who admire the B&O line of products as I've begun to in the last couple of...
    Posted to Vintage Products (Forum) by sartana on 12-07-2010
  • Restore finish on my Beomaster 3000-2 (slide rule Type 2402)

    Hello. Original Beomaster owner from 1975. After 30 years of storage, I have occasion to take my Beomaster out and clean it up and put it on display. I have done a decent job on front and sliders as there was little if any discoloration on the plastic sliders but the poor wood looks like it is pretty...
    Posted to Vintage Products (Forum) by Dan Gleason on 03-09-2010
  • Re: Privat survey of Beolab 5000 - Beomaster 5000 producs

    Hi, Just signed up, just bought a BL5000, type 5303, Serie 2, serial number 66407 Beomaster 5000S Type 2007, serie 01, serial number 16757 also have a Beomaster 5000 type 2013, Serial number 74824, serie 01 I knew the Amp was defective when I bought it, am always up for a challenge! Turned out to have...
    Posted to Vintage Products (Forum) by Saskwatch on 11-11-2009
  • U70 Headphones

    I just picked up a set of B & O U70 Headphones They work fine, but I need to find out if anyone knows of anyone that does refoam and covering.of the ear pieces. Or is there a do it your self method. I would be grateful for any help. George
    Posted to Vintage Products (Forum) by jayzjayz66 on 01-13-2009
  • BeoMaster 3000 (2402). Tuner Pulley Cord Assembly

    I need to repair the tuner-pulley-slider using some fine tuner-pulley-thread in the assembly. (Mouse attack !). I have the spring !! Would anyone know the correct plan and proceedure to redo the tuner-pulley-slide-thread assembly ? ..... and where can I get some of the 'special' thread ? It seems...
    Posted to Vintage Products (Forum) by brasso on 11-16-2008
  • Beocord 1600 : Magical missing capacitors!

    G'day all, I'm in the process of repairing my old friend the Beocord 1600, and I've discovered more than a few leaky capacitors (tants and electros), so I went through the 1600 TRM kindly scanned by Peter, and got a list of all the caps so I can do a complete swapout. Much to my surprise...
    Posted to Vintage Products (Forum) by PCPete on 07-25-2008
  • Beovox 2702 & Beolab 1700 + Ipod?

    I have recently been scrounging around in my fathers old posetions, and came across these two B&O products from about 30 years back. Got them out and hooked them up then realised i had no input for them. Since i know the speakers will be of a very high quality i wondered is there a way to hook up...
    Posted to Vintage Products (Forum) by scottish_bam on 06-28-2008
  • Re: Balance slider for Beomaster 2200: Needed desperately!!

    HI Martin, Thanks for your advice. I have repaired the slider, but the problem which i thought it was causing still persists. there is a low hum in the laft bchannel, i thought it was due to a problem with the ballance control, bad contact, poo earth, but apparently not. The noise gets loader as i put...
    Posted to Vintage Products (Forum) by Jokinross on 03-21-2008
Page 1 of 2 (17 items) 1 2 Next >
Need a cable? Just ask Steve at Sounds Heavenly Need a cable? Just ask Steve at Sounds Heavenly Need a cable? Just ask Steve at Sounds Heavenly
Beoworld Security Certificate

SSL